UT3 WebAdmin Bug Tracker


Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000074 [UT3 WebAdmin] Back end minor always 2009-08-19 18:57 2009-09-13 22:18
Reporter KY2009 View Status public  
Assigned To elmuerte
Priority normal Resolution fixed  
Status closed   Product Version v1.16
Summary 0000074: Multi-/Co-Admin with restricted rights can not kick or ban players from server
Description I gave a co-admin user the following rights in Web-Admin
Access order:allow/deny
Allow patterns:
/current
/current/players
/logout
/current/change

changing the game is no problem, but if a player was disconnected from server by crash, the co-admin cannot kick the player. No return message shown.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0000075closedelmuerte Co-Admin chat console refresh every 5 seconds 

-  Notes
(0000118)
elmuerte (administrator)
2009-08-19 19:55

You should also give that admin access to

/current/data
/current/players/data
/current/change/data
/current/change/check

These "hidden" locations are used by the AJAX frontend for communication of various data.
I should probably change how that works, considering it's not obvious.
(0000119)
KY2009 (reporter)
2009-08-19 20:06

Very nice - kick works fine now :-)
Is there a list of more subs that are called from several functions?
Chat function is not so important for co-admins - but would be nice to have..

Bye the way - I am sure you all already know.. great work you do!!
(0000120)
elmuerte (administrator)
2009-08-19 20:22

This is more or less the full list:

/current
/current/data
/current/players
/current/players/data
/current/chat
/current/chat/data
/current/change
/current/change/data
/current/change/check
/console
/current/bots

/policy
/policy/bans
/policy/hashbans
/policy/session
/settings
/settings/general
/settings/general/passwords
/settings/gametypes
/settings/mutators
/settings/serveractors
/system/settingscache

/voting
/voting/profiles
/voting/profiles/data
/voting/maplist
/voting/mutators

/multiadmin

/settings/system
/system/allowancecache

/about
/data
/logout

(the last three can not be blocked)
(0000121)
KY2009 (reporter)
2009-08-21 19:37

Great!
Everything works now - thank you very much :-)

- Issue History
Date Modified Username Field Change
2009-08-19 18:57 KY2009 New Issue
2009-08-19 18:57 KY2009 Status new => assigned
2009-08-19 18:57 KY2009 Assigned To => elmuerte
2009-08-19 19:55 elmuerte Note Added: 0000118
2009-08-19 20:06 KY2009 Note Added: 0000119
2009-08-19 20:22 elmuerte Note Added: 0000120
2009-08-21 19:37 KY2009 Note Added: 0000121
2009-09-13 00:05 elmuerte Relationship added duplicate of 0000075
2009-09-13 00:05 elmuerte Duplicate ID 0 => 75
2009-09-13 00:05 elmuerte Status assigned => resolved
2009-09-13 00:05 elmuerte Fixed in Version => v1.17
2009-09-13 00:05 elmuerte Resolution open => fixed
2009-09-13 00:06 elmuerte Relationship replaced has duplicate 0000075
2009-09-13 22:16 elmuerte Status resolved => closed
2009-09-13 22:18 elmuerte Target Version => v1.17


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker